Файл Readme для AutoCAD 2007: введение

Файл Readme для AutoCAD 2007

Данный файл Readme содержит важную информацию о приложении AutoCAD® 2007, которая не отражена ни в печатной документации, ни в электронной справочной системе.

  • Установка, настройка и аппаратные средства
  • Обновление драйвера видеоадаптера
  • Черчение и редактирование
  • Печать/Публикация
  • Текст и язык
  • Информация для разработчиков приложений
  • Дополнительные сведения
  • Протокол команд и системных переменных
  • Товарные знаки


Установка, настройка и аппаратные средства

Установка и настройка

Установка из сдвоенной системы устройств для чтения CD/DVD дисков

  • Установка прерывается при попытке установить AutoCAD с вставленными одновременно компакт-дисками в каждое устройство сдвоенной системы устройств для чтения CD/DVD дисков. По требованию установить второй установочный диск программа установки не распознает диск во втором устройстве для чтения компакт-дисков. Для завершения установки необходимо вставить второй диск в то же устройство, в котором был установлен первый диск.

Справочная система HTML недоступна в случае попытки запуска с сетевого диска

  • Из-за ограничений, накладываемых Windows Security Update #896258 компании Microsoft, запуск справочной системы с сетевого диска невозможен. В частности, не функционирует управление ActiveX, запускающее разделы справочной системы из содержания. Вместо этого отображается предупреждение "Страница не может быть отображена".

Создание образов дисков

  • В компьютерной среде SATA RAID при неустойчивом лицензировании использование программного обеспечения для создания образов дисков продуктов Autodesk может привести к неполадкам с активацией продукта. При попытке активации продукта в среде SATA RAID отображается сообщение "Срок активации закончен".

Уведомление об ошибках

  • Сообщение об ошибке, которое появляется при неожиданном завершении работы AutoCAD, предлагает отправить отчет в Autodesk. Уведомления об ошибках помогают компании Autodesk определить и устранить многие неполадки в программе. Сообщение "Отчет об ошибке" похоже на сообщение, появляющееся при внезапном завершении работы приложения в системе с операционной системой Microsoft® Windows® XP. В уведомлении об ошибке записываются данные о той части продукта, которая использовалась при завершении рабочего сеанса. В окне сообщения об ошибке нажмите "Дополнительно", введите следующие данные, после чего нажмите "Отправить отчет":
    • Сведения об операциях, совершаемых в программе AutoCAD до внезапного завершения сеанса
    • Контактная информация

    Передача этих сведений поможет специалистам компании Autodesk воспроизвести ошибку и устранить ее как можно быстрее. Если при внезапном завершении сеанса программы AutoCAD не появляется сообщение "Отчет об ошибке", убедитесь, что для системной переменной REPORTERROR установлено значение 1.

Развертывания в 64-битовых операционных средах

  • Создание развертывания программы AutoCAD в 64-битовой системе XP выполняется медленее, нежели развертывания в 32-битовых системах XP. Мастер развертывания успешно создает изображение развертывания в 64-битовой системе, однако процесс в среднем выполняется на 5 минут дольше, нежели в 32-битовой системе.

Некоторые локализованные программы установки продукта версии 2006 не работают, если на компьютере уже установлены продукты версии 2007

  • Программа установки линии продуктов Autodesk 2007 устанавливает .NET Framework 2.0. Эта программа запрещает установку некоторых локализованных продуктов Autodesk 2006 после установки продукта версии 2007. Для установки продуктов версии 2006 следует повторно установить .NET 1.1 и соответствующий пакет обновления.
    1. Вставьте компакт-диск с продуктом на базе 2006 в устройство для чтения дисков.
    2. Перейдите к папке \Bin\acadFeui\support\dotnetfx\ и дважды нажмите на файле dotnetfx.exe для установки .NET 1.1.
    3. В той же папке дважды нажмите на файле NDP1.1sp1-KB867460-X86.exe для установки пакета обновления .NET 1.1 Service Pack1.

      Для установки локализованной версии

    4. перейдите к папке \Bin\acadFeui\support\dotnetfx\language\ и установите langpack.exe.
    5. Установите приложения версии 2006.

Лицензирование

Обновленная информация PLIST игнорируется

  • Обновленная информация PLIST игнорируется в распределенной лицензионной среде сервера. Периодически Autodesk обновляет информацию Списка продуктов (PLIST) в сетевом файле лицензии.

    Например, существующий файл лицензии, содержащий информацию PLIST, находится на первом сервере распределенной лицензионной среды сервера. В случае приобретения продукции Autodesk с лицензионным файлом, содержащим обновленную информацию PLIST, и размещения файла на другом сервере распределенной лицензионной среды, используются данные PLIST первого сервера, а не новые данные PLIST.

    Для использования обновленного файла PLIST необходимо получить новый лицензионный файл от Autodesk, содержащий последнюю информацию PLIST. Второй способ: следует добавить обновленный PLIST в первый сервер распределенной лицензионной среды.

Аппаратные средства

Ошибка среды SATA RAID

  • После активации и повторного запуска продукта отображается ошибка 0.1.0011 или 11.1.6011 и требуется повторная активация. Эта неполадка встречается в продуктах на базе Autodesk 2006 и 2007 на компьютерах с контроллерами SATA RAID.

    Способ устранения этой неполадки см. в разделе "Обновление активации Autodesk".

Обновление драйвера видеоадаптера

  • Для обеспечения оптимального режима работы программы необходимо проверить и обновить драйвер видеокарты. Для получения дополнительной информации см. раздел "Обновление драйвера видеокарты".

Приложения удаленного доступа

  • Не рекомендуется использовать приложения удаленного доступа любого типа вместе с AutoCAD, если программа AutoCAD настроена для работы с аппаратным ускорением. Большинство приложений удаленного доступа не поддерживают аппаратное ускорение, поэтому возможны возникновение общей ошибки отображения и неустойчивость работы. Если использование приложений удаленного доступа необходимо, отключите аппаратное ускорение или используйте переключатель командной строки /NOHARDWARE для запуска программы AutoCAD в режиме программного обеспечения.

Драйвер принтера Hewlett-Packard Designjet

  • Драйвер принтеров Hewlett-Packard серии Designjet не предоставляется компанией Autodesk на компакт-диске продукта. При необходимости драйвер можно загрузить с веб-сайта http://www.designjet.hp.com.


Обновление драйвера видеоадаптера

Рекомендуется проверить и обновить видеодрайвер для оптимизации AutoCAD. Для определения версии драйвера видеоадаптера используется следующая процедура.

Для определения версии драйвера

  1. Запустите AutoCAD.
  2. В командной строке введите 3dconfig.
  3. В диалоговом окне "Адаптивное ухудшение и оптимизация параметров" выберите элемент "Просмотр протокола оптимизации".
  4. В разделе "Устройство 3D графики" просмотрите сведения о драйвере видеоадаптера системы и о версии драйвера.

Если требуется обновить драйвер, перейдите на веб-сайт поставщика видеоадаптера, загрузите и установите последнюю версию драйвера для данного видеоадаптера и данной операционной системы.

Примечание: Если производитель видеоадаптера не предлагает обновления драйвера, посетите веб-сайт производителя системы. Такие компании, как IBM, Hewlett Packard и Dell часто предоставляют собственные системные драйверы.


Рисование и редактирование

Черчение и редактирование

Среда построения чертежа

Подложки DWF

  • Рекомендуется вставлять файлы подложки DWF в заблокированные слои во избежание их случайного редактирования. Если увеличить масштаб файлов подложки DWF, а затем применить метод выбора окна, подложка DWF выбирается, даже если кажется, что геометрия подложки не выбрана.
  • Состояние незагруженных подложек DWF меняется на "Загружено", если прикрепленные к ним чертежи повторно открываются. Это связано с тем, что файлы подложек DWF автоматически загружаются при открытии чертежей.
  • Файлы DWF, печатаемые в перевернутом виде, не отображаются корректно, если файлы прикреплены как подложки DWF. Рекомендуется воздерживаться от печати файлов DWF в перевернутом виде и не прикреплять файлы DWF, напечатанные в перевернутом виде.
  • Если в чертеже используется команда ССЫЛРЕД, а для вставки подложки DWF применяется команда ВСТБУФЕР, сохранить изменения невозможно. Отображается следующее сообщение:
    Не удается сохранить изменения, так как объекты в рабочем наборе связаны с объектами, не находящимися в рабочем наборе. Сессия работы функции "Ссылред" по-прежнему активна. Нажмите F2 после сворачивания диалогового окна, чтобы просмотреть список отсутствующих ссылок.
    Также это сообщение об ошибке отображается, если подложка DWF прикреплена к главному чертежу и выполняется попытка применить команду ДВФВСТАВИТЬ к этому же файлу подложки DWF во внешней ссылке во время работы команды ССЫЛРЕД. Не рекомендуется применять команды ДВФВСТАВИТЬ/ВСТБУФЕР к подложкам DWF во время работы команды ССЫЛРЕД. Для устранения неполадки с сохранением изменений ССЫЛРЕД удалите подложку DWF, прикрепленную или вставленную во время работы команды ССЫЛРЕД.
  • В случае прикрепления файла DWF в качестве подложки путь поиска подложки DWF отличается от путей прикрепленных ссылок чертежа (внешних ссылок) или файлов изображений. Например, если в папке \Мои документы находится подложка DWF с тем же именем, что и подложка DWF в папке текущего файла чертежа, используется подложка в папке "Мои документы". Для упрощения управления данными не рекомендуется использовать папку \Мои документы в качестве места хранения.

Инструментальные палитры

  • Инструментальные палитры данной версии продукта не следует использовать в предыдущих версиях.

Файлы адаптации с тем же именем

  • При загрузке фрагментов меню AutoCAD сначала выполняет поиск пути доступа к вспомогательным файлам (определенным на вкладке "Файлы" диалогового окна "Настройка"). При попытке загрузить файл адаптации (CUI), имя которого совпадает с именем другого файла, программа автоматически загружает файл, который находится в пути доступа к вспомогательным файлам, независимо от того, какой файл был указан. Во избежание путаницы используйте уникальные имена файлов.

Рабочие пространства

  • Если в диалоговом окне "Параметры рабочего пространства" (ПАРАМЕТРЫРП) выбран параметр "Автоматически сохранять изменения", текущее рабочее пространство автоматически сохранится при закрытии продукта. Однако рабочее пространство не сохранится, если закрыть AutoCAD при отсутствии открытых чертежей. Чтобы сохранить рабочее пространство после закрытия, используйте команду РПСОХРАНИТЬ для сохранения рабочего пространства перед закрытием последнего чертежа или следите за тем, чтобы при закрытии AutoCAD был открыт хотя бы один чертеж.

3D среда

AutoCAD 2007 предлагает новую среду 3D моделирования, доступ к которой осуществляется с помощью команды ВИЗСТИЛИ и выбора любого трехмерного стиля. 3D среда имеет следующие отличия от среды 2D черчения предыдущей версии:

  • В 3D не поддерживается порядок черчения.
  • Увеличено потребление ресурсов памяти.
  • Команды РЕГЕН и ВСЕРЕГЕН не устраняют полностью дефекты отображения, команда ВИЗСТИЛИ восстанавливает отображение.

Источники света

Источники света в блоках не освещают модели

  • Источники света, являющиеся частью блока, созданного с помощью команды БЛОК, не освещают модель. Источники света в блоках работают только в том случае, если чертеж с источником света был вставлен в другой чертеж. Для освещения модели источником света можно также расчленить блок, содержащий источник света.

Материалы

Команда ПОВТОРИТь из палитры "Материалы"

  • Команда "Повторить"не восстанавливает изменения, отмененные в палитре "Материалы". Например, если цвет материала был изменен с красного на синий, команда ОТМЕНИТЬ восстанавливает исходный красный цвет. Однако команда ПОВТОРИТЬ не восстанавливает синий цвет.

Процедурные материалы не преобразуются командой ПРЕОБРУСТАРМАТЕРИАЛ

  • Процедурные материалы, примененные к объектам моделей AutoCAD 2006, не преобразуются командой ПРЕОБРУСТАРМАТЕРИАЛ в версию AutoCAD 2007.

Анимационные приложения и тонирование

Вывод анимации

  • Для вывода анимации в форматы файлов MOV или WMV необходимо установить программы Quicktime или Media Player 9 (или более поздней версии).
  • Программа Quicktime Player не воспроизводит файлы MOV, сохраненные с использованием символов, не характерных для языка текущей операционной системы.

Динамический ввод

Динамический ввод и окно команд

  • Динамический ввод не является полной заменой окна команды. Для увеличения области построения чертежа окно ввода команд можно скрыть, однако для выполнения некоторых операций потребуется вывести его. При необходимости нажмите F2 для скрытия и отображения подсказок команд и сообщений об ошибках. Можно также разблокировать окно команды и использовать параметр "Автоматически убирать с экрана" для разворачивания окна.

Правила динамического ввода

  • Значения координат можно ввести в окне подсказки, а не в командной строке. Значения координат X,Y, вводимые для большинства команд, по умолчанию интерпретируются не в качестве абсолютных координат, как в предыдущих версиях продукта, а в качестве полярных. Для ввода относительных координат не требуется вводить знак at (@); необходимо ввести только значения относительного смещения. Для обозначения абсолютных координат используется префикс из символа решетки (#). Например, для перемещения объекта в исходную точку рисунка при запросе второй точки введите #0,0.
  • Системная переменная DYNPICOORDS определяет, используются ли при вводе с помощью мыши абсолютные или относительные координаты. Для временного переопределения этих параметров можно использовать символы-префиксы.
    • Чтобы ввести абсолютные координаты, когда в подсказке отображаются относительные координаты, введите символ #.
    • Чтобы ввести относительные координаты, когда отображаются абсолютные координаты, введите символ @.
    • Для ввода координат, заданных в мировой системе координат (МСК), введите * (звездочка).
  • При включенном вводе размера (DYNMODE = 2 или 3) и при вводе запятой (,), угловой скобки (<) или при выборе нескольких точек ручек, программа переключается в режим ввода с помощью указателя.
  • Если ввести размерное значение и нажать клавишу TAB, в поле отобразится значок блокировки и курсор будет ограничен введенным значением.
  • Если в подсказке динамического ввода ввести значение, когда курсор находится вне области построения чертежа и подсказка скрыта, возможны неожиданные результаты.

Ввод размеров и ручки

  • Изменено поведение программы в случае использования ручек для растяжения вершин при включенном вводе размеров (DYNMODE = 2 или 3). Появились различия при вводе одного значения направления-расстояния от ввода в предыдущих версиях, так как при этом теперь изменяется значение полной длины или угла сегментов, а не положение вершины. Для получения наилучших результатов отключите ввод размеров, установив для переменной DYNMODE значение 0 или 1, нажав F12 или кнопку динамического ввода (DYN) в строке состояния.

Ввод размеров - Редактирование с помощью ручек и углы

  • При использовании ручек для растяжения объектов или при создании объектов на указателе ввода размеров отображаются только острые углы. Т.е. все углы отображаются как меньшие или равные 180 градусам. Таким образом, угол 270 градусов отображается как угол, равный 90 градусам, независимо от направления угла, заданного в диалоговом окне "Единицы рисунка". При определении направления положительного угла в параметрах углов учитывается направление перемещения курсора.

Просмотр и выбор объектов

  • При переключении между объектами с помощью клавиши TAB программа работает по-другому в зависимости от параметра динамического ввода.
    • Для ввода размеров (DYNMODE=3): если выбрать несколько объектов с одной и той же ручкой, а затем нажать на ручке кнопку мыши, с помощью клавиши TAB можно последовательно просматривать размеры каждого выбранного объекта.
    • Для ввода с помощью мыши (DYNMODE=1): при вводе значения во время выполнения команды используйте для отображения дополнительного поля ввода левую угловую скобку (<) или запятую (,), а не клавишу TAB.

Вставка значений в поле динамической подсказки

  • Чтобы воспользоваться командой ВСТБУФЕР для вставки значений из буфера обмена Windows в поле динамической подсказки, прежде чем вставить запись следует ввести в поле подсказки букву, а затем удалить ее, вернувшись на одну позицию. Иначе запись будет вставлена в рисунок как текст.

Прочие проблемы черчения

Команда ПЛОСКСНИМОК в перспективе

  • Возможно неправильное создание итоговой геометрии при использовании команды ПЛОСКСНИМОК в режиме перспективы.

Ассоциативные размеры

  • Для включения ассоциативных размеров по умолчанию при каждом открытии чертежа следует добавить в файл acad2007doc.lsp, расположенный в каталоге Support, следующую строку:

    (устперем "DIMASSOC" 2)

Для обновления размеров в рисунке, измененном в одной их прежних версий программы, или содержащего внешние ссылки, исходные файлы которых были изменены, следует воспользоваться командой РЗМРЕГЕН. Для автоматического обновления размеров добавьте в файл acad2007doc.lsp, расположенный в каталоге Support, следующую строку:

(команда "РЗМРЕГЕН")

Сплошные заливки

  • Файлы чертежей, содержащих сплошную штриховку, могут быть больше по размеру, чем файлы чертежей с другими типами штриховок.

Непрямоугольные видовые экраны

  • Назначение прерывистой линии для непрямоугольного видового экрана может привести к созданию геометрии пространства модели, произвольно обрезанной внутри экрана или стать причиной нестабильной работы AutoCAD.
  • При выполнении команд JPGOUT, PNGOUT, BMPOUT и TIFOUT в компоновке, содержащей непрямоугольные видовые экраны с 3D визуальным стилем, если выбраны все объекты и видовые экраны, фрагменты других видовых экранов могут быть скрыты, в результате чего некоторые объекты могут не отображаться. Для точного растрового вывода следует пользоваться командой ПУБЛ.
  • Не замораживайте слои, содержащие непрямоугольные видовые экраны. Вместо этого отключите слои, содержащие непрямоугольные видовые экраны, или установите для параметра "Печать" значение "Непечатаемый". При замораживании слоя граница содержащегося на нем непрямоугольного видового экрана становится прямоугольной. Объекты, которые должны обрезаться непрямоугольной границей видового экрана, при регенерации рисунка или выводе его на печать не обрезаются должным образом. Для устранения подобной проблемы следует разморозить слой, а затем регенерировать рисунок.

Вложенные внешние ссылки

  • Можно разрешить вложенные внешние ссылки с относительными путями. Поиск пути осуществляется в исходном файле внешней ссылки, а не в открытом чертеже. Если внешняя ссылка не найдена, следует откорректировать путь в ее исходном файле чертежа, а не в открытом главном чертеже. Обработка относительных путей вложенных внешних ссылок теперь не зависит от значения системной переменной VISRETAIN.

Внешние ссылки

  • Из-за цикла опроса внешней ссылки возможны задержки во времени при попытке использования значка "Диспетчер внешних ссылок" для обновления внешних ссылок DWG. Связанные файлы DWG не будут готовы для обновления данным методом до тех пор, пока не появляется всплывающее уведомление на значке "Диспетчер внешних ссылок". Для ускорения процесса обновления используйте один из следующих методов:

    • Нажмите правую кнопку мыши на чертеже внешней ссылки в списке "Файл ссылок" палитры "Внешние ссылки" и выберите "Обновить".
    • Нажмите кнопку "Обновить все ссылки" в верхней части палитры "Внешние ссылки".
    • Введите -ССЫЛКА в командной строке и воспользуйтесь параметром "Обновить".
  • Если используется режим интерфейса одного документа (системная переменная SDI), палитра "Внешние ссылки" не доступна для управления файлами ссылок, прикрепленных к чертежу. Вместо этого отображается предыдущая версия диалогового окна. В случае прикрепления файла ссылки в режиме SDI и последующего отключения режима SDI для возврата к стандартному интерфейсу нескольких документов, палитра "Внешние ссылки" неправильно отображает текущие прикрепления до тех пор, пока чертеж не будет сохранен, а ссылка обновлена.

Организация проекта

Подшивки

  • Некоторые функции Диспетчера подшивок могут быть недоступны в следующих случаях:
    • Команда активна.
    • Не открыт ни один чертеж.
    • Подшивка блокирована другим пользователем.
    • Значок блокировки перед именем подшивки в Диспетчере подшивок показывает, что подшивка заблокирована. Необходимо навести курсор на значок блокировки и дождаться появления всплывающей подсказки, чтобы узнать, кто заблокировал подшивку.
  • При выборе подшивок в Диспетчере подшивок может неправильно отображаться состояние листа "Блокировано пользователем". Для обновления статуса следует открыть лист.
  • При удалении листа из подшивки и последующем импорте листа в подшивку поля, поля, в которых приведена информация о подшивке в блоках атрибутов, отображаются в виде знаков решетки. Чтобы это исправить, можно либо заново создать поле, либо заново вставить блок. Если поле создается заново из-за того, что лист уже находится в подшивке, следует использовать поле свойства подшивки, а не поле-заменитель.
  • Поля подшивки (выбранные в категории подшивки) отличаются от других типов файлов. По умолчанию другие типы полей обновляются автоматически при сохранении чертежа или при использовании команды РЕГЕН. В отличие от них, поля подшивок хранят последние использовавшиеся значения и отображают эти значения, если сведения, на которые ссылается поле подшивки, недоступны. Для обновления значения в поле подшивки используется команда ОБНПОЛЕ. Если сведения, на которые ссылается поле подшивки, все еще недоступны, значение поля будет отображаться как ####.

Использование одного файла DWT для параметров страниц и блоков в сети

  • Некоторые функции подшивки недоступны при одновременном доступе двух пользователей в сети к подшивке, использующей один файл шаблона чертежа для блоков-идентификаторов и блоков марок, шаблона листа и переопределения параметров листа. Во избежание этой проблемы не используйте один и тот же файл DWT для хранения параметров страницы и библиотек компонентов.


Печать/Публикация

Печать чертежей

Ориентация бумаги и чертежа

  • Некоторые модели плоттеров позволяют загружать лист бумаги одного и того же формата двумя способами: в книжной и альбомной ориентации. В этом случае один и тот же формат предлагается в списке дважды: например ANSI A (8.5 x 11") и ANSI A (11 x 8.5"). Большинство офисных принтеров поддерживают загрузку листа только одним способом, обычно в книжной ориентации.

    AutoCAD автоматически поворачивает чертеж таким образом, что лист отображается на экране с альбомной ориентацией, даже если бумага загружена в плоттер с книжной ориентацией. Для просмотра исходной ориентации листа используйте "Полный просмотр чертежа".

    В области "Ориентация чертежа" диалоговых окон "Параметры страницы" и "Печать" показано изображение с ориентацией листа при загрузке в плоттер. Буква A показывает ориентацию объектов при печати. Большинство настольных принтеров используют книжную ориентацию, а чертеж для просмотра повернут в альбомную ориентацию.

    Можно изменить ориентацию для принтеров системы Windows, нажав на изображении в диалоговом окне "Свойства" для принтера. Изменение этого параметра влияет только на размер области печати; изменение не влияет на ориентацию изображения для печати, которая была установлена в диалоговых окнах "Параметры страницы" и "Печать". Поэтому при печати чертежа на системном принтере Windows в диалоговом окне дополнительных свойств следует задать такую же ориентацию, как и при создании чертежа.

Ребра пересечения не всегда выводятся на печать

  • Ребра пересечения не печатаются, если для визуального стиля установлено значение, отличное от "2D каркас". Для устранения данной неполадки выполните следующее:
    1. Установите для визуального стиля значение "2D каркас".
    2. Включите переменную INTERSECTIONDISPLAY.
    3. Установите значение INTERSECTIONCOLOR.
    4. Распечатайте чертеж, установив для параметра "ВЭкран с раскрашиванием" значение "Скрытие линий".

Публикация рисунков

Градиентные объекты

  • При публикации в файле DWF градиентные объекты могут сдвигаться или исчезать. Эта проблема возникает в случаях, когда значение градиентного разрешения отлично от векторного. Чтобы устранить эту ошибку, отредактируйте свойства драйвера DWF6 ePlot и установите значение "Градиентное разрешение" равным значению "Векторное разрешение". Для редактирования дополнительных свойств в диалоговом окне "Печать" нажмите кнопку "Свойства" > узел "Дополнительные свойства" > кнопку "Дополнительные свойства".

Файлы DWF

  • Растровые изображения в подложках DWF не печатаются, если выполняется печать в DWF.
  • Печать файлов подложки DWF, содержащих растровые изображения, может привести к непредсказуемым результатам.

Публикация в Интернете

  • В программе DWF Viewer версии 6.5 выбор шаблонов "Список чертежей" и "Список и сводка" при использовании команды ОПУБЛИКОВАТЬ невозможен. Неполадка будет устранена в следующих версиях программы DWF Viewer.


Текст и язык

Текст

Переопределения шрифтов в файлах DXF

  • При сохранении файла DXFTM данные о переопределении шрифта автоматически применяются ко всему объекту многострочного текста, если ему был назначен крупный шрифт SHX. Поэтому при изменении текущего стиля текста и определении другого шрифта изменения не будут касаться многострочного текста, если снова не применить стиль ко всему объекту многострочного текста.

Язык

Поддержка нескольких языков

  • Свойства чертежа в AutoCAD 2007 сохраняются в символах Unicode. Например, если требуется сохранить чертеж формата 2007, содержащий свойства чертежа на нескольких языках, в формате 2004, свойства чертежа преобразуются в символы языка установленной системы Windows. Если текст не удается преобразовать, он сохраняется в кодах CIF (\U+nnnn).
  • При сохранении чертежа формата 2007 в формате 2004 любое новое символьное имя (например имя разметки листа, имя стиля текста, имя размера текста), создаваемое в AutoCAD 2007, сохраняется в языке, используемом при создании символьного имени.
  • При копировании и вставке символов, созданных с помощью языка, отличного от системного, символы могут отображаться неправильно. Это можно исправить в текстовом редакторе, используемом в месте редактирования.

    Исправление ошибок для отображения исходного языка
    1. Дважды нажмите кнопку мыши в области текста, чтобы открыть текстовый редактор, используемый в месте редактирования.
    2. Нажмите правую кнопку мыши в редакторе. Выберите "Набор символов" и задайте исходный язык.
  • Для просмотра и редактирования чертежей, содержащих символы, которые не существуют в языках, указанных для используемой операционной системы, убедитесь, что в системе установлена поддержка дополнительных языков. Язык можно указать в диалоговом окне "Язык и региональные стандарты" в панели управления Windows. (Текст, в котором используются шрифты SHX, можно просмотреть, не включая поддержку дополнительных языков.)
  • Текстовые стили для азиатских языков, использующие SHX и файлы большого шрифта, могут поддерживать только символы из той же кодовой страницы. Например, текстовые стили, в которых используется японский крупный шрифт, не поддерживают немецкие или корейские символы. (Английские символы, входящие во все кодовые страницы, поддерживаются.) Поддержка нескольких языков обеспечивается только для тех текстовых стилей неазиатских языков, в которых используются шрифты SHX, а крупные шрифты отключены. В шрифте SHX должны быть определены требуемые символы.
  • Чтобы не возникало проблем при использовании многострочного текста на нескольких языках в операционных системах, поддерживающих различные языки, в текстовом редакторе, используемом в месте редактирования, установите шрифт TrueType.
  • Функция поддержки нескольких языков отсутствует в некоторых ранних версиях AutoCAD. Например, при сохранении файла в формате AutoCAD® 2000 содержимое многострочного текста на нескольких языках может быть повреждено. Возникновение проблем более вероятно при открытии и сохранении чертежа в операционной системе, в которой настройки языка отличаются от настроек системы, в которой чертеж был сохранен в последний раз.

Имена папок или файлов

  • Windows считает имена файлов из двухбайтовых символов, различающиеся лишь верхним и нижним регистром, одинаковыми. Это может вызвать ошибки при импортировании и стать причиной перезаписи файлов.

    AutoCAD 2006, AutoCAD LT 2006 и предыдущие версии не поддерживали систему Unicode. В случае использования чертежей в предыдущих версиях, не поддерживающих систему Unicode, для обеспечения совместимости используйте символы ASCII при сохранении файлов, вставке внешних ссылок и указании путей к папкам.

Неполадки, связанные с двухбайтовыми символами

Названия панелей инструментов

  • Название создаваемой панели инструментов не должно состоять только из однобайтовых цифр. В названии панели инструментов можно использовать только английские алфавитные символы или двухбайтовый текст.

Имена источников данных

  • Символы с кодами (например 0xx??41 и 0xx??61), используемые в именах источников данных, могут обрабатываться неправильно. Данная проблема возникает при создании нескольких источников данных с использованием указанных в конфигурации базы данных необятельных имен (японских). В результате некоторые имена источников данных могут не выводиться. При возникновении данной проблемы можно изменить имя отсутствующего источника данных на другое.

Циклический перебор подобъектов и объектов

  • Циклический перебор подобъектов и объектов с помощью комбинаций клавиш CTRL + ПРОБЕЛ и SHIFT + ПРОБЕЛ не работает в китайских (КНР и Тайвань) версиях Microsoft Windows. При работе с китайской ОС данные комбинации клавиш выполняют следующее:
    • CTRL + ПРОБЕЛ переключает режимы китайской ОС.
    • SHIFT + ПРОБЕЛ переключает между двубайтовыми и однобайтовыми английскими символами.

    В операционной системе предусмотрено изменение комбинаций клавиш. Можно изменить стандартные действия комбинаций CTRL + ПРОБЕЛ и SHIFT + ПРОБЕЛ на действия, не конфликтующие с режимом комбинаций CTRL + ПРОБЕЛ и SHIFT + ПРОБЕЛ в программе AutoCAD.

Отображение текста

Вертикальный текст для азиатских языков

  • SHX-шрифты - создание текста с вертикальной ориентацией и использованием SHX-шрифтов и больших шрифтов производится так же, как и в предыдущих версиях. Для получения наилучших результатов используйте команду для однострочного текста ТЕКСТ, а не МТЕКСТ. Вертикальный стиль можно выбрать в диалоговом окне "Текстовые стили".

    Шрифты TrueType - по-прежнему можно выбирать шрифты, имена которых начинаются со знака @, но в данном случае текст автоматически поворачивается на 270 градусов. (В предыдущих версиях необходимо было поворачивать текст вручную.) Для вертикально ориентированного текста теперь поддерживается перемещение курсора по вертикали.

Отображение шрифта

  • Если шрифт по умолчанию не поддерживает символы, введенные в текстовом редакторе, используемом в месте редактирования (команда МТЕКСТ), обычно он заменяется альтернативным шрифтом.
  • Коды CIF или MIF, введенные с помощью текстового редактора, используемого в месте редактирования (команда МТЕКСТ), или команды ДТЕКСТ, теперь автоматически преобразуются для отображения реальных символов.

Запись команды

AltGR и комбинации клавиш

  • Комбинация AltGR+ любая клавиша прерывает запись команды. Это вызвано влиянием комбинации Ctrl+Alt для выдавливания невидимых граней. При использовании раскладки клавиатуры AltGR для устранения неполадки установите для параметра IMPLIEDFACE значение 0 (ноль).

Азиатские крупные шрифты, поставляемые с продуктом

С продуктом поставляются следующие крупные шрифты:

  • @extfont2.shx - японский шрифт, используемый со шрифтами SHX для вертикального написания (несколько символов поворачиваются для правильного отображения в тексте с вертикальной ориентацией)
  • bigfont.shx - японский шрифт
  • chineset.shx - китайский шрифт (традиционное письмо)
  • extfont.shx - японский шрифт
  • extfont2.shx - японский шрифт
  • gbcbig.shx - китайский шрифт (упрощенное письмо)
  • whgdtxt.shx - корейский шрифт
  • whgtxt.shx - корейский шрифт
  • whtgtxt.shx - корейский шрифт
  • whtmtxt.shx - корейский шрифт

Обновленный файл bigfont.ini

  • Метод обработки дополнительных крупных шрифтов SHX в AutoCAD 2007 отличается от предыдущих версий продукта. Если в файлах чертежей используются дополнительные крупные шрифты SHX, необходимо добавить имена крупных шрифтов SHX и идентификатор их кодовой страницы в файл bigfont.ini в папке Support. О способе добавления информации см. в разделе заголовка файла bigfont.ini.


Информация для разработчиков приложений

Изменения, которые могут повлиять на сценарии

На существующие сценарии могут повлиять следующие команды или системные переменные:

  • ADCNAVIGATE - при использовании команды ЦУПЕРЕЙТИ для открытия DesignCenter больше не требуется нажимать клавиши ENTER или ESC для отображения подсказки "Путь входа".
  • УДЛИНИТЬ - если перед вводом команды УДЛИНИТЬ предварительно не был выбран объект при появлении подсказки "Выбрать удлиняемые объекты", то теперь отображается запрос на указание противоположного угла секущей рамки. Это изменение может повлиять на существующие сценарии, в которых вызывается команда УДЛИНИТЬ и задается точка выбора, не выбирающая объекты. Чтобы исправить старые сценарии, можно исключить пункты, в которых не выбираются объекты.
  • -ВСТАВИТЬ - в случае использования нового параметра "Одинаковый масштаб" в диалоговом окне "Описание блока" запрос на ввод отдельных значений коэффициентов масштаба по осям X,Y,Z не отображается при вставке блока с помощью команды -ВСТАВИТЬ.
  • МЕНЮЗАГР - команда МЕНЮЗАГР в AutoCAD 2006 и последующих версиях по умолчанию загружает только CUI-файлы. Для загрузки меню MNU или MNS-файла в AutoCAD 2006 или последующей версии необходимо в явном виде включить в имя файла расширение согласно нижеприведенному примеру:

    (команда "менюзагр" "myMenu.mnu")

    Однако, вместо того чтобы изменять код, настоятельно рекомендуется открыть старые файлы меню в AutoCAD 2007 перед запуском приложений, в которых они используются. AutoCAD автоматически преобразует их в CUI-файлы, которые загружаются имеющимся кодом, использующим имя файла без расширения.

    Старый код, в котором указаны расширения MNU, MNS или MNC, следует изменить на ссылку на файл CUI, а приложения на основе AutoCAD 2007 должны поставляться с файлами CUI, а не MNU, MNS или MNC.

  • ОБРЕЗАТЬ - если перед вводом команды ОБРЕЗАТЬ предварительно не был выбран объект при появлении подсказки "Выбрать обрезаемые объекты", то теперь отображается запрос на указание противоположного угла секущей рамки. Это изменение может повлиять на существующие сценарии, в которых вызывается команда ОБРЕЗАТЬ и задается точка выбора, не выбирающая объекты. Чтобы исправить старые сценарии, можно исключить пункты, в которых не выбираются объекты.

Visual LISP

Видимость процесса AutoCAD

  • Вызываемые при загрузке программы сценарии AutoLISP® должны проверять видимость процесса AutoCAD. Если приложение невидимо, то выполнять пакет не следует, так как приложение может выполнять вывод на печать или публикацию в фоновом режиме. Для проверки видимости процесса AutoCAD служит свойство "Видимость" объекта "Приложение" в объектной модели AutoCAD.

Уведомления

  • В некоторых случаях уведомления vlr-sysVarWillChange и vlr-sysVarChanged появляются несколько раз для одного изменения системной переменной.

Ручки

  • AutoCAD более не поддерживает ручки на невыбранных объектах. В результате аргумент ручки функции AutoLISP sssetfirst игнорируется и функция ssgetfirst возвращает значение nil для первого возращенного набор объектов.

Цвет

  • При полной установке AutoCAD программы для работы с полноцветными изображениями находятся в папке \Sample\VisualLISP в файле color-util.lsp. Программы, которые можно использовать для операций, относящихся к полноцветным изображениям, например получение компонентов с номером цвета, преобразование индекса или имени цвета в полноцветное значение, возврат кода группы DXF и работа со списком элементов.

    Следующие функции AutoLISP предоставляют доступ к интерфейсу пользователя для работы с полноцветными изображениями:

    (acad_truecolordlg color [allowbylayer] [currentlayercolor]).
    Запрос цветов с помощью диалогового окна. Параметр цвета представляет собой точечную пару, описывающую цвет по умолчанию; первым элементом точечной пары должен быть один из кодов группы DXF, относящихся к цвету (62, 420 или 430). Если имеется параметр allowbylayer и его значение отлично от nil, отображаются кнопки "ПоСлою" и "ПоБлоку". При успешном выполнении операции функция возвращает список одной или нескольких точечных пар, описывающих выбранный цвет. Последняя точечная пара в списке показывает выбранный цвет. Функция возвращает значение nil, если пользователь отменит отображение диалогового окна.

    (acad_truecolorcli color [allowbylayer] [alternatePrompt]).
    Запрашивает цвета в командной строке. Первые два параметра аналогичны acad_truecolordlg, а третий параметр является дополнительной строкой подсказки. Если эта строка пропущена, в качестве значения по умолчанию используется значение "Новый цвет".

Функции entmod и entmake

  • В AutoCAD 2004 и более ранних версиях функции entmod и entmake по-другому работают с цветом. Код группы DXF 62 содержит значения индекса цвета AutoCAD (ACI), а код 420 хранит значения полноцветных цветов. В случае конфликта полноцветного значения и значения ACI AutoCAD использует значение 420, поэтому прежде чем использовать значение кода 62, следует удалить значение кода 420. Для получения дополнительных сведений выполните полную установку AutoCAD и просмотрите файл color-util.lsp, находящийся в папке \Sample\VisualLISP.

Ошибки загрузки

  • Если при выполнении команды ЗАГРУЗИТЬ для файла VLX с отдельным пространством имен возникает ошибка, возможно, некоторые функции были экспортированы в пространство имен текущего документа до обнаружения ошибки. Чтобы обеспечить экспорт в текущий документ правильной версии всех функций, необходимо исправить ошибку, выполнить повторную компиляцию и перезагрузить файл VLX.
  • После того, как команда НПИЗАГР загрузит частичное меню в MDI, файл MNL для этого меню загружается один раз для каждого открытого документа, причем взаимодействие с пользователем осуществляется в текущем документе. Чтобы предотвратить появление ненужных печатных сообщений или пользовательских запросов при инициализации программы AutoCAD с несколькими рисунками, рекомендуется не включать взаимодействие с пользователем в код MNL LISP. Вместо этого загрузите необходимые файлы AutoLISP с помощью кода MNL для последующего выбора элементов меню. Используйте файл acad.lsp или acaddoc.lsp для выполнения кода AutoLISP при открытии рисунка.

Отображение диалогового окна "Многодокументная среда"

  • Диалоговое окно "Многодокументная среда" позволяет изменять функции по умолчанию при инициализации среды AutoLISP. Это диалоговое окно отображается в следующих случаях:
    • В разделе реестра "Не отображать значение AcadLspAsDocDlg" установлено значение 0.
    • Сценарии не запущены и приложения AutoLISP и ActiveX не запущены.
    • Для системной переменной ACADLSPASDOC установлено значение 0.
    • В пути поиска AutoCAD существует файл acad.lsp.
    • В пути поиска AutoCAD не существует файл acaddoc.lsp.
    • Для системной переменной SDI установлено значение 0.
    Если выполняются все эти условия, то диалоговое окно "Многодокументная среда" отображается в каждом сеансе при первом открытии второго документа.

ActiveX и VBA

Видимость процесса AutoCAD

  • Вызываемые при загрузке программы сценарии VBA должны проверять видимость процесса AutoCAD. Если приложение невидимо, то выполнять пакет не следует, так как приложение может выполнять вывод на печать или публикацию в фоновом режиме. Для проверки видимости процесса AutoCAD служит свойство "Видимость" объекта "Приложение" в объектной модели AutoCAD.

Изменения интерфейса расширения COM

Приведенный ниже интерфейс расширения COM внедрен в первичный интерфейс:
Старый интефейс | Внедрен в
IAcadAttribute2 | IAcadAttribute
IAcadAttributeReference2 | IAcadAttributeReference
IAcadBlock2, IAcadBlock3 | IAcadBlock
IAcadBlockReference2 | IAcadBlockReference
IAcadExternalReference2 | IAcadExternalReference
IAcadHatch2 | IAcadHatch
IAcadLayer2 | IAcadLayer
IAcadLayers2 | IAcadLayers
IAcadMInsertBlock2 | IAcadMInsertBlock
IAcadMLine2 | IAcadMLine
IAcadModelSpace2, IAcadModelSpace3 | IAcadModelSpace
IAcadMText2 | IAcadMText
IAcadPaperSpace2, IAcadPaperSpace3 | IAcadPaperSpace
IAcadPreferencesFiles2 | IAcadPreferencesFiles
IAcadPreferencesOutput2 | IAcadPreferencesOutput
IAcadPViewport2 | IAcadPViewport
IAcadTable2 | IAcadTable
IAcadText2 | IAcadText
IAcadUtility2 | IAcadUtility
IAcadView2 | IAcadView

Это изменение относится только к коду, непосредственно использующему интерфейс COM. Оно должно быть понятным клиентам соответствующих классов автоматизации VBA.


Дополнительные сведения

Некоторые программы установки неанглийских версий программ серии 2006 вызывают сбой в случае, если уже установлены программы серии 2007

Средство установки для программ серии Autodesk 2007 выполняет установку .NET Framework 2.0. Из-за этого невозможно установить некоторые неанглийские версии программ Autodesk 2006 после установки программ серии 2007. Для установки программ серии 2006 необходимо переустановить .NET 1.1 и все соответствующие пакеты обновления.

  1. Вставить в дисковод CD-ROM установочный диск программы из серии 2006.
  2. Перейти к папке\Bin\acadFeui\support\dotnetfx\ и дважды нажать файл dotnetfx.exe для установки .NET 1.1.
  3. В той же папке дважды нажать файл NDP1.1sp1-KB867460-X86.exe для установки пакета обновления 1 .NET 1.1.

Установка неанглийской версии:

  1. Перейти к папке \Bin\acadFeui\support\dotnetfx\language\ и запустить файл langpack.exe.
  2. Установить программы серии 2006.

Переведенные имена шаблонов для панели «Редактор материалов»

Имена шаблонов материалов не переведены в окнах «Материалы» и диалоговом окне «Свойства инструментов».
Ниже находится список переведенных имен шаблонов:

Английский | Русский
Ceramic Tile, Glazed | Керамическая плитка, глянцевая
Fabric | Ткань
Glass - Clear | Стекло - прозрачное
Glass - Translucent | Стекло - полупрозрачное
Ideal Diffuse | Идеальный диффузный
Masonry | Каменная кладка
Metal | Металл
Metal - Brushed | Металл - очищенный
Metal - Flat | Металл - ровный
Metal - Polished | Металл - полированный
Mirror | Зеркальное отражение
Paint Flat | Матовая окраска
Paint Gloss | Глянцевая окраска
Paint Semi Gloss | Полуглянцевая окраска
Paper | Бумага
Paper - Translucent | Бумага - полупрозрачная
Plastic | Пластик
Stone | Камень
Stone Polished | Камень, полированный
Water | Вода
Wood Unfinished | Необработанное дерево
Wood Varnished | Лакированное дерево

Изменения командной строки

Обратите внимание на следующие изменения командной строки.

a) Команды с измененными именами

ПРЕДШЕСТВУЮЩАЯ КОМАНДА | НОВАЯ КОМАНДА
БОПЕРАЦИЯ | БЛОКРЕАКТ
БНАБОРОПЕРАЦИЙ | БЛОКРЕАКТНАБОР
БЛОКСКРЫТЬВИД | БЛОКСКРЫТЬ
БЛОКПОКАЗАТЬВИД | БЛОКПОКАЗАТЬ
КОМАНДНАЯСТРОКА | КОМСТР
CUI | НПИ
ЭКСПОРТCUI | НПИЭКСПОРТ
ИМПОРТCUI | НПИИМПОРТ
ЗАГРУЗКАCUI | НПИЗАГР
ВЫГРУЗКАCUI | НПИВЫГР
ЛОМЛИНРАЗМ | РЗМИЗЛОМ
QКЗАКРЫТЬ | БКЗАКРЫТЬ
ПАРАМЕТРЫVT | ПАРАМЕТРЫПВ
СОХРАНЕНИЕРП | РПСОХРАНИТЬ
ВОССТАНРИСУНКА | ВОССТАНЧЕРТЕЖА
СКРЫТЬВОССТАНРИСУНКА | СКРЫТЬВОССТАНЧЕРТЕЖА
РЕЖИМРИС | РЕЖИМЧРТ
WHOHAS | КЕМОТКРЫТ
3-МАССИВ | 3DМАССИВ
3-СЕКПЛ | 3DСЕКПЛ
3-ПОРБИТА | 3DПОРБИТА
3-РАССТ | 3DРАССТ
ПУБЛ3МДВФ | ПУБЛ3DДВФ
3-ГРАНЬ | 3DГРАНЬ
3-СЕТЬ | 3DСЕТЬ
3-ОРБИТА | 3DОРБИТА
3-ОРБЦЕНТР | 3DОРБЦЕНТР
3-ПАН | 3DПАН
3-ПЛИНИЯ | 3DПЛИНИЯ
ИМПОРТ3ДС | ИМПОРТ3DС
3-ШАРНИР | 3DШАРНИР
3-ПОКАЗАТЬ | 3DПОКАЗАТЬ
3-ЗЕРКАЛО | 3DЗЕРКАЛО
3-ПОВЕРНУТЬ | 3DПОВЕРНУТЬ

b) Измененные имена параметров командной строки

Команда | Предшествующий параметр | Новый параметр
БЛОКПАРАМ | Перпендикулярное | Нормаль
РЕЖИМРАСКР | 2М каркас | 2dкаркас
РЕЖИМРАСКР | 3М каркас | 3dкаркас

Не рекомендуется устанавливать AutoCAD 2007 в папку, в названии которой имеются 8-битные или 2-байтовые символы (например, кириллические или азиатские символы). Установка AutoCAD 2007 в такие папки может привести к некоторый функциональным проблемам при использовании «Мастера установки плоттеров» и «Редактора параметров плоттера».

Просмотр документации из обозревателя компакт-диска и Acrobat Reader

Для просмотра документации из обозревателя компакт-диска необходима программа Acrobat Reader. Если она отсутствует на компьютере, необходимо установить ее, следуя выводимым на экран инструкциям

Системная переменная CPLOTSTYLE выдает переведенное значение «ПоЦвету» при запросе из VBA

Если переменной CPLOTSTYLE присвоено значение ПоЦвету (ByColor), то при вызове VBA-инструкции debug. print (ThisDrawing.GetVariable("CPLOTSTYLE")) будет возвращено переведенное значение «ПоЦвету», а не английское ByColor.


Протокол команд и системных переменных

Источники информации об AutoCAD

Подробные сведения о данном продукте и его новых функциях можно найти в следующих источниках:

  • Семинар по новым возможностям (меню "Справка")
  • Справочная система (меню "Справка")
  • Документация для разработчиков (меню "Справка" > "Дополнительные ресурсы")
  • Группы пользователей Autodesk (AUGI) (меню "Справка" > "Дополнительные ресурсы")
  • Веб-сайт Autodesk по адресу http://www.autodesk.com

Команды

Новые команды

Команда | Описание
3DALIGN | Выравнивание объектов по другим объектам в 2D и 3D видах.
3DДВФ | Отображение диалогового окна "Экспорт 3D DWF".
3DОБЛЕТ | Включение режима облета, что позволяет перемещаться в любом направлении, в том числе вне плоскости XY.
3DОБХОД | Изменение вида 3D чертежа в интерактивном режиме, что создает эффект обхода вокруг модели.
3DПЕРЕНЕСТИ | Отображение ручки перемещения в 3D виде и перемещение объектов на указанное расстояние в указанном направлении.
3DПОВЕРНУТЬ | Отображение ручки поворота в 3D виде и вращение объекта вокруг базовой точки.
3DСОРБИТА | Управление интерактивным обзором объектов в 3D с помощью орбиты без зависимостей.
ГРПРЕД | Удаление протокола из 3D простых и сложных тел.
EXPORTTOAUTOCAD | Создание нового файла DWG с расчлененными AD-объектами.
VSSAVE | Сохранение визуального стиля.
АНИМТРАЕКТ | Сохранение анимации вдоль пути в 3D модели.
-ВЗАИМОД | Выделение перекрывающихся 3D тел. (версия командной строки)
-ВИЗСТИЛИ | Создание и изменение визуальных стилей, применение визуального стиля к видовому экрану. (версия командной строки)
ВИЗСТИЛИ | Создание и изменение визуальных стилей, применение визуального стиля к видовому экрану.
ВИЗСТИЛИЗАКР | Закрытие Диспетчера визуальных стилей.
ВНССЫЛКИ | Отображение палитры "Внешние ссылки".
ВНССЫЛКИЗАКРЫТЬ | Закрытие палитры "Внешние ссылки".
ВЫДАВГРАНЬ | Вытягивание ограниченных областей.
ГЕОПОЛОЖЕНИЕ | Указание широты и долготы местоположения.
-ГРАФНАСТР | Доступ к интерфейсу командной строки для параметров конфигурации 3D графической системы.
ДВФВСТАВИТЬ | Вставка подложки DWF в текущий чертеж.
ДВФРЕГУЛ | Регулировка подложки DWF из командной строки.
ДВФРЕЗ | Применение границ подрезки для определения подобласти подложки DWF.
ИЗВЛРЕБРА | Создание каркасной геометрии путем извлечения ребер из 3D тела или поверхности.
ИЗЛОМРАЗРЕЗ | Добавление сегмента с изломом в объект-сечение.
КЛЕЙМО | Клеймение ребра на 3D теле.
-КОПИЯВСЛОЙ | Копирование одного или нескольких объектов в другой слой. ((версия командной строки)
КОПИЯВСЛОЙ | Копирование одного или нескольких объектов в другой слой. (встроенная программа Express Tool)
МАТЕРИАЛПРИСВ | Добавление материалов в объекты с помощью слоя.
МАТЕРИАЛСООТВ | Отображение ручки наложения материалов для регулировки наложения на грань или объект.
МАТЕРИАЛЫ | Управление, применение и изменение материалов.
МАТЕРИАЛЫЗАКР | Закрытие окна "Материалы".
НАБПАРАМТОНИР | Задание наборов параметров тонирования, параметров тонирования для повторного использования при тонировании изображения.
ОБХОДОБЛЕТНАСТР | Задание параметров обхода и облета.
ОБХСЛОЯ | Отображение слоев чертежа в динамическом режиме. (встроенная программа Express Tool)
ПИРАМИДА | Создание 3D пирамиды.
ПЛОСКПОВ | Создание плоской поверхности.
ПЛОСКСНИМОК | Создание 2D представления всех 3D объектов в текущем виде.
ПОЛИТЕЛО | Создание 3D политела.
ПОСЕЧЕНИЯМ | Создание 3D тела или поверхности по сечениям с помощью набора двух или более кривых.
ПРЕОБРВПВРХ | Преобразование объектов в поверхности.
ПРЕОБРВТЕЛО | Преобразование утолщенных полилиний и кругов в 3D тела.
ПРЕОБРУСТАРМАТЕРИАЛ | Преобразование материалов, созданных в предыдущих версиях, в материалы формата AutoCAD 2007.
ПРЕОБРУСТАРСВЕТ | Преобразование источников света, созданных в предыдущих версиях, в источники света формата AutoCAD 2007.
ПРОЖЕКТОР | Создание прожектора.
ПСЕВДОРАЗРЕЗ | Включение псевдоразреза для выбранного объекта-сечения.
ПУЛЬТУПР | Открытие окна "Пульт управления".
ПУЛЬТУПРЗАКР | Закрытие окна "Пульт управления".
РЕЖИМТОНОТКЛ | Закрытие палитры "Дополнительные параметры тонирования", если она отображается.
СВОЙСТВАСОЛНЦАЗАКР | Закрытие окна "Свойства солнца".
СВОЙСТВАСОЛНЦА | Открытие палитры "Солнце" и установка свойств солнца.
СДВИГ | Создание 3D тела или поверхности путем перемещения 2D кривой вдоль пути.
СЕКПЛОСКОСТЬ | Создание объекта-сечения, выполняющего функцию секущей плоскости 3D объекта.
СЛОЙБЛК | Блокировка слоя выбранных объектов. (встроенная программа Express Tool)
СЛОЙВКЛ | Включение всех слоев. (встроенная программа Express Tool)
СЛОЙЗМР | Замораживание слоя выбранных объектов. (встроенная программа Express Tool)
-СЛОЙИЗМНЕСК | Замена слоя выбранного объекта на слой назначения. (версия командной строки)
СЛОЙИЗМНЕСК | Замена слоя выбранного объекта на слой назначения. (встроенная программа Express Tool)
-СЛОЙОБЪЕД | Объединение выбранных слоев в слой назначения. (версия командной строки)
СЛОЙОБЪЕД | Объединение выбранных слоев в слой назначения. (встроенная программа Express Tool)
СЛОЙОВЭ | Выделение слоя объекта в текущий видовой экран. (встроенная программа Express Tool)
СЛОЙОТД | Отделение слоя выбранных объектов, все остальные слои отключаются. (встроенная программа Express Tool)
СЛОЙОТДОТМ | Включение слоев, отключенных при последнем выполнении команды СЛОЙОТД. (встроенная программа Express Tool)
СЛОЙОТКЛ | Отключение слоя выбранного объекта. (встроенная программа Express Tool)
СЛОЙРАЗБЛ | Разблокировка слоя выбранного объекта. (встроенная программа Express Tool)
СЛОЙРМР | Размораживание всех слоев. (встроенная программа Express Tool)
СЛОЙТЕК | Замена слоя выбранных объектов на текущий слой. (встроенная программа Express Tool)
-СЛОЙУДАЛ | Удаление слоя выбранного объекта или всех объектов в слое, затем удаление слоя из чертежа. (версия командной строки)
СЛОЙУДАЛ | Удаление слоя выбранного объекта или всех объектов в слое, затем удаление слоя из чертежа. (встроенная программа Express Tool)
СЛОЙУСТЕК | Выбор слоя выделенного объекта в качестве текущего. (встроенная программа Express Tool)
СМЕНАПРОСТР | Перемещение объектов из пространства модели в пространство листа, и наоборот. (встроенная программа Express Tool)
СПИРАЛЬ | Создание 2D или 3D спирали.
СПИСОКСВЕТ | Вывод окна "Источники света в модели" для добавления или изменения источников света.
СПИСОКСВЕТЗАКР | Закрытие окна "Источники света в модели".
СРЕДАТОН | Управление затуманенностью (кажущимся удалением) объектов.
ТЕКВИЗСТИЛЬ | Установка визуального стиля в текущем видовом экране.
ТОЛЩИНА | Создание 3D тела путем утолщения поверхности.
ТОНИРОКНО | Отображение окна тонирования без запуска задачи тонирования.
ТОНИРПОДРЕЗ | Задание конкретной области в изображении для тонирования.
ТОЧСВЕТ | Создание точечного источника света.
УДАЛСВЕТ | Создание удаленного источника света.

Изменившиеся команды

Команда | Описание
3DОРБИТА | Управление интерактивным обзором объектов в 3D виде.
3DПАН | Запуск интерактивного 3D вида, возможность перетаскивания вида по горизонтали и по вертикали в перспективном виде.
3DПОКАЗАТЬ | Увеличение и уменьшение масштаба в перспективном виде.
3DШАРНИР | Изменение цели вида в направлении движения мыши.
БВЫБОР | Создание наборов объектов на основе результатов фильтрации.
ВЗАИМОД | Выделение перекрывающихся 3D тел.
ВИД | Сохранение и восстановление именованных видов, видов камеры, видов разметки листа и стандартных видов.
ВРАЩАТЬ | Создание 3D тела или поверхности путем вращения 2D объектов вокруг оси.
ВЫБРАТЬ | Размещение выбранных объектов в предыдущем наборе объектов.
ВЫДАВИТЬ | Создание 3D тела или поверхности путем выдавливания объекта или плоской грани в указанном направлении и на указанное расстояние.
ВЫРОВНЯТЬ | Выравнивание объектов по другим объектам в 2D и 3D видах.
-ВЭКРАН | Создание нескольких видовых экранов пространства модели или пространства листа. (версия командной строки)
ГРАФНАСТР | Сведения о параметрах конфигурации 3D графической системы.
ДВИД | Задание параллельной проекции и вида в перспективе с помощью камеры и цели.
ИЗМЕНИТЬ | Изменение свойств существующих объектов.
-ИЗОБ | Управление изображениями. (версия командной строки)
ИЗОБ | Управление изображениями.
ИЗОБВСТАВИТЬ | Вставка нового изображения в текущий чертеж.
ИЗОБКАЧЕСТВО | Управление качеством вывода на экран изображений.
-ИЗОБРЕГУЛ | Управление значениями яркости, контрастности и прозрачности изображений. (версия командной строки)
ИЗОБРЕГУЛ | Упрвление значениями яркости, контрастности и прозрачности изображений.
ИЗОБРЕЗ | Применение границ подрезки для определения подобласти объекта изображения.
КАМЕРА | Установка камеры и местоположения цели для создания и сохранения 3D перспективных видов объектов.
КЛИН | Создание пятистороннего 3D тела с наклонной гранью, сужающейся вдоль оси X.
КОНУС | Создание 3D тела с круглым или эллиптическим основанием, симметрично сужающегося к точке либо круглой или эллиптической плоской грани.
КОПИРОВАТЬСВ | Применение свойств выбранных объектов к другим объектам.
НАСТРОЙКА | Настройка параметров программы.
НЛНАСТР | Изменение свойств отображения линий в 2D каркасах.
НПИ | Управление такими элементами настраиваемого пользовательского интерфейса, как рабочие пространства, панели инструментов, меню, контекстные меню и комбинации клавиш
СОЕДИНИТЬ | Объединение объектов в один непрерывный объект.
-ОЧИСТИТЬ | Удаление из чертежа неиспользуемых именованных элементов, например описаний блоков и слоев. (версия командной строки)
ОЧИСТИТЬ | Удаление из чертежа неиспользуемых именованных элементов, например описаний блоков и слоев.
ПАРАМЛИСТ | Управление разметкой листа, устройством печати, размером листа и другими параметрами для каждого нового варианта компоновки.
-ПБЛОК | Запись объектов или блока в новый файл чертежа. (версия командной строки)
ПБЛОК | Запись объектов или блока в новый файл чертежа.
ПЕЧАТЬ | Вывод чертежа на печать на плоттер, принтер или в файл.
ПОДШИВКА | Запуск Диспетчера подшивок.
ПОЛЕ | Создание объекта многострочного текста с полем, автоматически обновляемым при изменении значения поля.
ПРЯМОУГ | Построение прямоугольной полилинии.
ПСК | Управление пользовательскими системами координат.
ПУБЛ | Публикация чертежей в файлы DWF или плоттеры.
РАЗРЕЗ | Разрезание тела плоскостью или поверхностью.
РАСЧЛЕНИТЬ | Разбиение составного объекта на компоненты.
РЕДТЕЛ | Редактирование граней и ребер объектов 3D тел.
РЕЖИМРАСКР | Запуск команды ТЕКВИЗСТИЛЬ.
РЕЖИМТОН | Отображение палитры "Дополнительные параметры тонирования" для доступа к дополнительным параметрам тонирования.
РЕЖИМЧРТ | Установка сетки и привязки, полярного отслеживания и отслеживания объектной привязки, режимов объектной привязки и динамического ввода.
СВЕТ | Создание источника света.
СВИД | Создание и управление видовыми экранами листа.
СВОЙСТВА | Изменение свойств объекта.
СЕТКА | Отображение сетки в текущем видовом экране, не включаемом в печать.
СКРЫТЬ | Регенерация трехмерной каркасной модели с подавлением скрытых линий.
СОХРИЗОБ | Сохранение тонированного изображения в файл.
СПИСОК | Отображение информации базы данных для выбранных объектов.
ССЫЛЗАКР | Сохранение или отмена изменений, внесенных в ссылку (внешнюю ссылку или блок) при местном редактировании.
ССЫЛКА | Запуск команды ВНССЫЛКИ.
ССЫЛРЕД | Выбор внешней ссылки или ссылки блока для редактирования.
ТОНИРОВАТЬ | Создание фотореалистично раскрашенного изображения трехмерной каркасной или твердотельной модели.
ТОР | Создание 3D кольцеобразного тела.
-ФОРМКОМПЛЕКТ | Создание комплектов файлов для передачи по Интернету. (версия командной строки)
ФОРМКОМПЛЕКТ | Создание комплектов файлов для передачи по Интернету.
ЦИЛИНДР | Создание трехстороннего 3D тела с круглым или эллиптическим основанием сверху и снизу.
ШАГ | Ограничение передвижения курсора в указанных интервалах.
ШАР | Создание 3D шара.
ЯЩИК | Создание 3D ящика.

Удаленные или устаревшие команды

Команда | Описание
3DDWFPUBLISH | Создание 3D DWF-файлов трехмерных моделей (заменена на команду 3DДВФ)
БИБМАТ | Импорт и экспорт материалов в библиотеку материалов. (замена на команду МАТЕРИАЛЫ)
ЛАНДБИБ | Управление библиотеками объектов ландшафта. (нет замены)
ЛАНДНОВЫЙ | Добавление в чертеж реалистичных элементов ландшафта, например деревьев и кустов. (нет замены)
ЛАНДРЕД | Редактирование объекта ландшафта. (нет замены)
МАТЕРИАЛ | Управление материалами для тонирования. (замена на команду МАТЕРИАЛЫ)
НАЛТЕК | Отображение материалов на объекты. (замена на команду МАТЕРИАЛСООТВ)
ПОКМАТ | Вывод списка типов материалов и метод прикрепления к выбранному объекту. (замена на команду СПИСОК)
ПРОСМОТР | Вывод на экран изображения формата BMP, TGA или TIFF. (нет замены)
СТАТ | Отображение статистики тонирования. (объединена с командой ТОНИРОКНО)
СЦЕНА | Управление сценами в пространстве модели. (нет замены)
ТОНЭКР | Единственный эффект - сохранение целостности сценариев. (нет замены)
ТУМАН | Управление затуманенностью (кажущимся удалением) объектов. (замена на команду СРЕДАТОН)
ФОН | Настройка фона сцены. (объединена с командой ВИД)
ЭКСПОРТ3ДС | Экспорт в файл 3D Studio (3DS). (нет замены)

Системные переменные

Новые системные переменные

Системная переменная | Описание
3DDWFPREC | Управление точностью публикации 3D DWF.
CAMERADISPLAY | Включение или отключение отображения объектов камеры в текущем чертеже.
CAMERAHEIGHT | Сохранение стандартной высоты созданных объектов камеры.
CLEANSCREENSTATE | Сохранение значения, указывающего, включена ли очистка экрана. (только для чтения)
CMATERIAL | Установка материала новых объектов.
CSHADOW | Установка свойства отображения тени для 3D объекта.
DASHBOARDSTATE | Определение активности или неактивности окна пульта управления.
DEFAULTLIGHTING | Включение или выключение стандартного освещения.
DEFAULTLIGHTINGTYPE | Задание типа стандартного освещения.
DIMARCSYM | Управление отображением символа дуги в размере длины дуги.
DIMFXL | Установка общей длины выносных линий, начинающихся от размерной линии в направлении исходной точки размера.
DIMFXLON | Управление фиксацией длины выносных линий.
DIMJOGANG | Определение угла поперечного сегмента размерной линии в размере радиуса с изломом.
DIMLTEX1 | Установка типа линии для первой выносной линии.
DIMLTEX2 | Установка типа линии для второй выносной линии.
DIMLTYPE | Установка типа линии для размерной линии.
DIMTFILL | Управление фоном размерного текста.
DIMTFILLCLR | Установка цвета для фона текста в размерах.
DRAGVS | Установка визуального стиля при создании 3D объектов.
DWFFRAME | Задание видимости рамки DWF и вывода ее на печать.
DWFOSNAP | Определение, включена ли объектная привязка для файлов DWF, прикрепленных к файлу DWG.
ERSTATE | Определение режима окна "Внешние ссылки": неактивно, активно/видимо или активно/автоматическое скрытие.
GRIDDISPLAY | Управление режимом отображения и границами отображения для сетки.
GRIDMAJOR | Управление частотой основных линий сетки по сравнению со вспомогательными линиями сетки.
GRIDUNIT | Задание шага сетки (X и Y) для текущего видового экрана.
GTAUTO | Управление автоматическим отображением ручек при выборе объектов в 3D пространстве.
GTDEFAULT | Управление автоматическим запуском команд 3DПЕРЕНЕСТИ, 3DПОВЕРНУТЬ и 3DМАСШТАБ при запуске (соответственно) команд ПЕРЕНЕСТИ, ПОВЕРНУТЬ и МАСШТАБ в 3D виде.
GTLOCATION | Управление стандартным расположением ручек.
IMPLIEDFACE | Управление обнаружением неявных граней.
INTERFERECOLOR | Установка цвета вырезающих объектов.
INTERFEREOBJVS | Установка визуального стиля для вырезающих объектов.
INTERFEREVPVS | Установка визуального стиля для текущего видового экрана при использовании команды INTERFERENCE.
LATITUDE | Задание широты модели чертежа.
LEGACYCTRLPICK | Задание клавиш для циклического выбора и задание режима для комбинации CTRL + нажатие левой кнопки мыши.
LIGHTGLYPHDISPLAY | Управление отображением источников света.
LIGHTLISTSTATE | Индикатор отображения на экране окна "Источники света в модели".
LOFTANG1 | Установка конусного ограничения с помощью первого поперечного сечения при операции по сечениям.
LOFTANG2 | Установка конусного ограничения с помощью последнего поперечного сечения при операции по сечениям.
LOFTMAG1 | Установка величины конусного ограничения с помощью первого поперечного сечения при операции по сечениям.
LOFTMAG2 | Установка величины конусного ограничения с помощью последнего поперечного сечения при операции по сечениям.
LOFTNORMALS | Управления нормалями объекта по сечениям в точках пересечения сечений.
LOFTPARAM | Управление формой тел и поверхностей по сечениям.
LONGITUDE | Определение долготы модели чертежа.
MATSTATE | Индикатор отображения на экране окна "Материалы".
NORTHDIRECTION | Определение угла солнца относительно севера.
OSOPTIONS | Автоматическое подавление объектных привязок на объектах штриховки и при использовании линамической ПСК.
PERSPECTIVE | Определение режима отображения текущим видовым экраном перспективного рабочего вида.
PSOLHEIGHT | Установка стандартной высоты для смещенного тела, созданного командой ПОЛИТЕЛО.
PSOLWIDTH | Установка стандартной ширины для смещенного тела, созданного командой ПОЛИТЕЛО.
PUBLISHALLSHEETS | Управление режимом заполнения списка диалогового окна публикации.
RENDERPREFSSTATE | Сохранение значения, указывающего, открыта ли палитра "Дополнительные параметры тонирования".
SHADOWPLANELOCATION | Управление местоположением невидимой наземной плоскости, используемой для отображения теней.
SHOWHIST | Управление свойством "Показать протокол" для тел чертежа.
SOLIDHIST | Управление параметром стандартного свойства протокола для новых и существующих объектов.
STEPSIZE | Определение величины шага в текущих единицах в режиме "Обход".
STEPSPERSEC | Определение числа шагов в минуту в режиме "Обход".
SUNPROPERTIESSTATE | Индикатор отображения на экране окна "Свойства солнца".
SUNSTATUS | Управление распространением света солнца на видовом экране.
TIMEZONE | Установка часового пояса для исследования солнца.
UCSDETECT | Управление активностью захвата динамической ПСК.
VISUALSTYLES | Отображение палитры Диспетчера визуальных стилей, предназначенной для создания и изменения визуальных стилей, а также применения визуального стиля к видовому экрану.
VSBACKGROUNDS | Включение или отключение отображения фона в текущем видовом экране.
VSCURRENT | Сохранение имени визуального стиля, применяемого к текущему видовому экрану.
VSEDGECOLOR | Установка цвета кромок.
VSEDGEJITTER | Управление степенью похожести линии на нарисованную карандашом.
VSEDGEOVERHANG | Продолжение линий за точку пересечения для достижения эффекта ручного вычерчивания.
VSEDGES | Управление типами кромок, отображаемых на видовом экране.
VSEDGESMOOTH | Определение угла отображения линий сгиба.
VSFACECOLORMODE | Управление режимом обработки цвета граней.
VSFACESTYLE | Управление режимом отображения граней в текущем видовом экране.
VSHALOGAP | Установка значения недовода в визуальном стиле, применяемом к текущему видовому экрану.
VSHIDEPRECISION | Управление точностью скрытия и отображением теней в визуальном стиле, применяемом к текущему видовому экрану.
VSINTERSECTIONCOLOR/P> | Определение цвета полилиний пересечения в визуальном стиле, применяемом к текущему видовому экрану.
VSINTERSECTIONEDGES | Определение режима отображения ребер пересечения в визуальном стиле, применяемом к текущему видовому экрану.
VSINTERSECTIONLTYPE | Управление режимом отображения скрытых линий в текущем видовом экране и установка их типа линии.
VSLIGHTINGQUALITY | Установка качества освещения в текущем видовом экране.
VSMATERIALMODE | Управление режимом отображения материалов в текущем видовом экране.
VSMONOCOLOR | Установка цвета для монохромного отображения граней.
VSOBSCUREDCOLOR | Определение цвета скрытых линий в визуальном стиле, применяемом к текущему видовому экрану.
VSOBSCUREDEDGES | Управление режимом отображением скрытых ребер.
VSOBSCUREDLTYPE | Определение типа линии скрытых линий в визуальном стиле, применяемом к текущему видовому экрану.
VSOPACITY | Управление прозрачностью граней в текущем видовом экране.
VSSHADOWS | Управление режимом отображения теней в визуальном стиле.
VSSILHEDGES | Управление отображением кривых силуэта тел в визуальном стиле, применяемом к текущему видовому экрану.
VSSILHEDGEWIDTH | Определение ширины в пикселах для отображения ребер силуэта в текущем видовом экране.
VSSPECULAR | Управление режимом отображения бликов на гранях без материалов в текущем видовом экране.
VSSTATE | Сохранение значения, указывающего, открыто ли окно "Визуальные стили".
ZOOMWHEEL | Переключение режима зумирования для колеса мыши.

Изменившиеся системные переменные

Системная переменная | Описание
AUTOSNAP | Управление отображением маркера, всплывающей подсказки и магнита автопривязки.
BACKZ | Сохранение значения смещения задней плоскости подрезки от целевой плоскости в единицах чертежа в текущем видовом экране.
DBLCLKEDIT | Управление режимом реагирования на двойное нажатие кнопки мыши.
DELOBJ | Сохранение или удаление объектов, используемых для создания других объектов, из базы данных чертежа.
DISPSILH | Управление режимом отображения кривых силуэта твердотельных объектов в режиме "Каркас".
FRONTZ | Сохранение значения смещения передней плоскости подрезки от целевой плоскости для текущего видового экрана.
LENSLENGTH | Сохранение длины линз. (только для чтения)
PICKADD | Замена текущего набора объектов на последовательные наборы выбора или добавление последовательных наборов выбора к текущему набору объектов.
POLARMODE | Управление параметрами полярного отслеживания и отслеживания объектной привязки.
PROJECTNAME | Назначение имени проекта текущему чертежу.
SURFU | Установка плотности поверхности для ПОЛРЕД "Сглаживание в направлении M".
SURFV | Установка плотности поверхности для ПОЛРЕД "Сглаживание в направлении N".
TRACKPATH | Управление отображением линий полярного отслеживания и отслеживания объектной привязки.

Удаленные или устаревшие

Нет


Товарные знаки

Зарегистрированные товарные знаки компании Autodesk, Inc. в США и/или других странах: 3D Studio, 3D Studio MAX, 3D Studio VIZ, 3ds max, ActiveShapes, ActiveShapes (логотип), Actrix, ADI, AEC-X, ATC, AUGI, AutoCAD, AutoCAD LT, Autodesk, Autodesk Design Review, Autodesk Envision, Autodesk Inventor, Autodesk Map, Autodesk MapGuide, Autodesk RealDWG, Autodesk Streamline, Autodesk WalkThrough, Autodesk World, AutoLISP, AutoSketch, backdraft, Biped, bringing information down to earth, Buzzsaw, CAD Overlay, Character Studio, Cinepak, Cinepak (логотип), cleaner, Codec Central, combustion, Design Your World, Design Your World (логотип), EditDV, Education by Design, gmax, Heidi, HOOPS, Hyperwire, i-drop, IntroDV, lustre, Mechanical Desktop, ObjectARX, Physique, Powered with Autodesk Technology (логотип), ProjectPoint, RadioRay, Reactor, Revit, VISION*, Visual, Visual Construction, Visual Drainage, Visual Hydro, Visual Landscape, Visual Roads, Visual Survey, Visual Toolbox, Visual Tugboat, Visual LISP, Volo, WHIP! и WHIP! (логотип).

В США и/или других странах товарными знаками корпорации Autodesk являются: AutoCAD Learning Assistance, AutoCAD LT Learning Assistance, AutoCAD Simulator, AutoCAD SQL Extension, AutoCAD SQL Interface, AutoSnap, AutoTrack, Built with ObjectARX (логотип), burn, Buzzsaw.com, CAiCE, Cinestream, Civil 3D, cleaner central, ClearScale, Colour Warper, Content Explorer, Dancing Baby (изображение), DesignCenter, Design Doctor, Designer's Toolkit, DesignKids, DesignProf, DesignServer, Design Web Format, DWF, DWFit, DWG Linking, DXF, Extending the Design Team, GDX Driver, gmax (логотип), gmax ready (логотип), Heads-up Design, jobnet, mass, ObjectDBX, onscreen onair online, Plasma, PolarSnap, Productstream, Real-time Roto, Render Queue, Visual Bridge, Visual Syllabus и Where Design Connects.